FAQ  •  Login

Sounds in my server

<<

Neolantis

Posts: 20

Joined: Mon Dec 17, 2012 6:41 pm

Post Sat Dec 22, 2012 12:58 pm

Sounds in my server

Does anyone have information on how to put say sounds into my HLDM server...An intensive search has produced no results...

Thanks
Image
<<

ughsupport

Posts: 124

Joined: Sat Oct 03, 2009 11:56 am

Post Sat Dec 22, 2012 3:25 pm

Re: Sounds in my server

Looks like the saysounds plugin is installed and running according to sm plugin list. Your saysounds.cfg seems to refer to files that don't exist in your sound directory though, for example the file "saysound/rocket1.mp3" does not exist anywhere. I think you'll need to upload the mp3/wav files referenced in your cfg file.
<<

Neolantis

Posts: 20

Joined: Mon Dec 17, 2012 6:41 pm

Post Sat Dec 22, 2012 8:27 pm

Re: Sounds in my server

Thank you for your reply...as you have seen I have say sound files that I have obtained from information I have pieced together when I was searching for "how to"

My problem, more specifically, is what I think must be the last piece of the puzzle...I don't know where to put the sounds..It is probably the easiest piece...I just didn't see a directory that was being referenced in a cfg file. So maybe the question is which .cfg file is stating a path? Where is it looking?

Keep in mind, what I have in my ftp (in several different folders), are files that I downloaded from a random site, my point being that it is their sound configuration set up, but I don't have the sounds, and respectfully, I knew that

The bottom line is that I want to be able to have sound bites (and songs) that are triggered by chat commands. Is that a huge project? Is there documentation that is available. I figured if there was I can just compare and adjust accordingly.

If I ask too much, just let me know. Not sure if this is something I should have known before hand. I assumed that I would be able to Google, and be overloaded with info. haha
Image
<<

ughsupport

Posts: 124

Joined: Sat Oct 03, 2009 11:56 am

Post Sat Dec 22, 2012 10:54 pm

Re: Sounds in my server

According to http://forums.alliedmods.net/showthread.php?t=82220 sounds go relative to the "sound" directory.
<<

Neolantis

Posts: 20

Joined: Mon Dec 17, 2012 6:41 pm

Post Sun Dec 23, 2012 6:32 am

Re: Sounds in my server

ughsupport wrote:According to http://forums.alliedmods.net/showthread.php?t=82220 sounds go relative to the "sound" directory.


Ok, thank you...The thread you gave is exactly where I got the file and info from originally.
Thread says
Sounds go in your mods "sound" directory (such as sound/misc/filename.wav)

I get confused with
mod directory
&
sound/misc

I will read through it again and see if I missed something.

I guess I started in the middle instead of the beginning when trying to figure out the sound stuff.
Thanks for your help...Ted

I am very happy with the server, for the record...works great and having fun!
Image
<<

ughsupport

Posts: 124

Joined: Sat Oct 03, 2009 11:56 am

Post Sun Dec 23, 2012 9:31 am

Re: Sounds in my server

Your FTP login already points to the mod directory itself, for HL2DM it's orangebox/hl2mp. So you would want to put sounds in the sound directory when you login via FTP.
<<

Neolantis

Posts: 20

Joined: Mon Dec 17, 2012 6:41 pm

Post Mon Dec 24, 2012 4:10 am

Re: Sounds in my server

ughsupport wrote:Your FTP login already points to the mod directory itself, for HL2DM it's orangebox/hl2mp. So you would want to put sounds in the sound directory when you login via FTP.

So I put a sound in the sound folder...the bottom or 13th folder down when signing in to the ftp. Is that correct?

It is not working yet...but if that is the correct place, then I can start looking at other things, like typing it in the cfg file wrong or whatever.

Thanks
Image
<<

ughsupport

Posts: 124

Joined: Sat Oct 03, 2009 11:56 am

Post Mon Dec 24, 2012 5:35 am

Re: Sounds in my server

Your configuration looks correct to us, it should play welcome.mp3 for admins only upon join. A few things to try:

1. According to the second post on http://forums.alliedmods.net/showthread ... 20&page=91, some mp3s may not work depending on bitrate and encoding. To eliminate this possibility, try using .wav instead to test.

2. When joining, check your client console and see if an error shows up.

If neither of these suggestions help let us know and we'll troubleshoot further.
<<

Neolantis

Posts: 20

Joined: Mon Dec 17, 2012 6:41 pm

Post Mon Dec 24, 2012 10:56 am

Re: Sounds in my server

ughsupport wrote:Your configuration looks correct to us, it should play welcome.mp3 for admins only upon join. A few things to try:

1. According to the second post on http://forums.alliedmods.net/showthread ... 20&page=91, some mp3s may not work depending on bitrate and encoding. To eliminate this possibility, try using .wav instead to test.

2. When joining, check your client console and see if an error shows up.

If neither of these suggestions help let us know and we'll troubleshoot further.


I don't see any errors on sound
this is what i get after changing sound to a wav...this is assuming it is in the right place:

maxplayers set to 2
Steam config directory: c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\platform\config
CClientSteamContext logged on = 1
Parent cvar in client.dll not allowed (cl_particle_scale_upper)
Parent cvar in client.dll not allowed (cl_particle_scale_lower)
Unknown command "cl_thirdperson"
Can't use cheat cvar cam_snapto in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_ideallag in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_idealdelta in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_idealyaw in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_idealpitch in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_idealdist in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_idealdistright in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_idealdistup in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar cam_collision in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_maxpitch in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_minpitch in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_maxyaw in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_minyaw in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_maxdistance in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_mindistance in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_orthowidth in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar c_orthoheight in multiplayer, unless the server has sv_cheats set to 1.
Unknown command "sv_backspeed"
Not playing a local game.
Discarding repository 'maps/soundcache/_other.cache' due to version change
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_other.cache!
Discarding repository 'maps/soundcache/_sharedprecache.cache' due to version change
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_sharedprecache.cache!
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_other_rebuild.cache!
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_sharedprecache.cache!
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_other.cache!
Discarding repository 'maps/soundcache/_other_rebuild.cache' due to version change
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_other_rebuild.cache!
Touched 0 cached files
Unable to persist cache 'maps/soundcache/_other_rebuild.cache', check file permissions
Discarding repository 'maps/soundcache/_sharedprecache.cache' due to version change
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_sharedprecache.cache!
Touched 0 cached files
Unable to persist cache 'maps/soundcache/_sharedprecache.cache', check file permissions
Discarding repository 'maps/soundcache/_other.cache' due to version change
Unable to remove c:\program files (x86)\steam\steamapps\neolantis\half-life 2 deathmatch\hl2mp\maps\soundcache\_other.cache!
Touched 0 cached files
Unable to persist cache 'maps/soundcache/_other.cache', check file permissions
Unable to persist cache 'maps/soundcache/_other_rebuild.cache', check file permissions
Network: IP 192.168.1.2, mode MP, dedicated No, ports 27015 SV / 27005 CL
Can't use cheat cvar fog_start in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar fog_end in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar fog_startskybox in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar fog_endskybox in multiplayer, unless the server has sv_cheats set to 1.
Can't use cheat cvar r_farz in multiplayer, unless the server has sv_cheats set to 1.
Connecting to 108.61.73.101:14700...
Connected to 108.61.73.101:14700

Deathmatch
Map: cok_crazy_sniper_and_cams
Players: 1 / 10
Build: 5153
Server Number: 2

env_cubemap used on world geometry without rebuilding map. . ignoring: wood/woodfloor007a
env_cubemap used on world geometry without rebuilding map. . ignoring: wood/woodfloor008a
env_cubemap used on world geometry without rebuilding map. . ignoring: wood/woodfloor007a_c17
env_cubemap used on world geometry without rebuilding map. . ignoring: custom/alfzelia
env_cubemap used on world geometry without rebuilding map. . ignoring: plaster/plasterwall034c
env_cubemap used on world geometry without rebuilding map. . ignoring: building_template/building_template010c
env_cubemap used on world geometry without rebuilding map. . ignoring: tile/tilefloor011a
env_cubemap used on world geometry without rebuilding map. . ignoring: metal/citadel_metalwall072c
env_cubemap used on world geometry without rebuilding map. . ignoring: metal/citadel_metalwall072b
env_cubemap used on world geometry without rebuilding map. . ignoring: metal/metalcombine001
env_cubemap used on world geometry without rebuilding map. . ignoring: metal/metaldoor018a
env_cubemap used on world geometry without rebuilding map. . ignoring: building_template/building_trainstation_template001b
No pure server whitelist. sv_pure = 0
Neolantis connected
Compact freed 856064 bytes
Redownloading all lightmaps
Console: Neolantis (Pos 3 with 1224 points) has connected
Image
<<

ughsupport

Posts: 124

Joined: Sat Oct 03, 2009 11:56 am

Post Mon Dec 24, 2012 2:18 pm

Re: Sounds in my server

Sorry, we're not sure what the problem is. We tried changing admin to 0 (we changed it back after our test) and tried joining the server. No text and no welcome sound on join.
Next

Return to Support / Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.